Cómo configurar el entorno de desarrollo BlackBerry

Posted by admin on March 12, 2013

Usted puede desarrollar aplicaciones de software de BlackBerry si instala las herramientas adecuadas en su equipo: una aplicación Java Software Development Kit (JDK) y un BlackBerry Java Development Environment (JDE). Estas herramientas se pueden descargar gratuitamente de la Sun Microsystems y Research In Motion sitios web.

El JDK proporciona las herramientas básicas para la compilación de código fuente de Java en el código de bytes utilizado por el intérprete de Java. El JDK también provee el intérprete de Java que se utiliza para ejecutar muchas de las herramientas de desarrollo en el JDE.

El JDE proporciona las herramientas específicas de BlackBerry para la transformación de bytecode de Java en el formato especial utilizado por el intérprete Java como en dispositivos de mano BlackBerry. También proporciona las herramientas de depuración y edición necesarios para el desarrollo de software grave.

Comience por determinar qué versión del sistema operativo BlackBerry (OS) usted planea en la focalización. Esto determina qué versión de la JDE de usar, que a su vez determina la versión del JDK para instalar.

La regla general es la siguiente: siempre use una versión JDE igual o menor que la versión del sistema operativo que usted está apuntando. Por ejemplo, si usted está apuntando OS 4.3 se puede utilizar de JDE 4.0, 4.1, 4.2 ó 4.3 para desarrollar su aplicación, pero no 4.5, 4.7 o 5.0. (Las versiones de JDE saltado 4.4., 4.6, 4.8 y 4.9, por cierto.) Esto no es una regla estricta, porque a veces se puede usar una versión posterior JDE para crear aplicaciones que funcionan en versiones anteriores del sistema operativo, pero RIM doesn ‘ garantía de t que esas aplicaciones funcionan o que incluso se carga en las versiones anteriores del sistema operativo. (Desde luego, no se cargará si utiliza una API que no es compatible con las versiones anteriores.) Para estar seguro, a continuación, que siempre desea utilizar la versión JDE correcto para las generaciones final de su solicitud, incluso si utiliza una versión diferente para el desarrollo JDE provisional. (Hay algunas buenas características en las versiones más recientes de JDE, después de todo.)

Una vez que haya determinado qué JDE utilizar, descargar e instalar la versión correcta de la JDK. Para las versiones de JDE 4.0.2 y anteriores, JDK 1.4 se requiere. Para las versiones de JDE 4.1 a 4.2, utilice JDK 1.5. Para las versiones 4.3 y superiores, se requiere JDK 1.6. Puede descargar el JDK apropiado desde el sitio web de Sun Microsystems. (Tenga en cuenta que las versiones JDK 1.4 y 1.5 son bastante viejo y ya no están soportados oficialmente por parte de Sun, pero aún están disponibles para su descarga y son requeridos por las versiones de JDE mayores.)

Después de instalar el JDK apropiado, descargar e instalar el JDE deseado en el sitio de desarrolladores de BlackBerry. Usted tendrá que registrarse para obtener una cuenta gratuita en el sitio. No se olvide de unirse al programa de desarrolladores de BlackBerry de RIM, mientras estás en ello.

Las diferentes versiones del JDK y el JDE pueden coexistir en la misma máquina sin problemas si se instalan en el orden correcto: JDK 1.4, seguido por JDE 4.0, JDK 1.5 seguido por JDE 4,1 a 4,2; JDK 1.6 seguido por las versiones JDE restantes. De lo contrario, tendrá que alterar las rutas utilizadas por los diferentes lotes y los archivos ejecutables en el JDE de usar la versión correcta de JDK – un poco de molestia, sin duda, pero no difícil de hacer en absoluto.

Categories: Software

Comments are closed.